const regex = /(?:\| #033\[0m)(.*)(?:\.xcade\.net)(?:.*)(GET |POST )(\/.*)(?: HTTP)(?:.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\| #033\\[0m)(.*)(?:\\.xcade\\.net)(?:.*)(GET |POST )(\\\/.*)(?: HTTP)(?:.*)', 'gm')
const str = ` #033[0;36;1mnginx.1 | #033[0mlinkedinmiddleware-integrations.xcade.net 172.27.0.13 - fac4d3l1nked1nus3r [24/Sep/2019:14:25:04 +0000] TLSv1.2/ECDHE-RSA-AES256-GCM-SHA384 "GET /application/asiainspection HTTP/1.1" 200 103 "-" "-"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}