# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\| #033\[0m)(.*)(?:\.xcade\.net)(?:.*)(GET |POST )(\/.*)(?: HTTP)(?:.*)"
test_str = " #033[0;36;1mnginx.1 | #033[0mlinkedinmiddleware-integrations.xcade.net 172.27.0.13 - fac4d3l1nked1nus3r [24/Sep/2019:14:25:04 +0000] TLSv1.2/ECDHE-RSA-AES256-GCM-SHA384 \"GET /application/asiainspection HTTP/1.1\" 200 103 \"-\" \"-\""
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.