using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0*(?:\+?972)?(\d+)";
string substitution = @"0$1";
string input = @"0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}