const regex = /0*(?:\+?972)?(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0*(?:\\+?972)?(\\d+)', 'g')
const str = `0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
`;
const subst = `0$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);