// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"0*(?:\+?972)?(\d+)").unwrap();
let string = "0527691234
00527691234
527691234
00972527691234
972527691234
+972527691234
";
let substitution = "0$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}