import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0*(?:\\+?972)?(\\d+)";
final String string = "0527691234\n"
+ "00527691234\n"
+ "527691234\n"
+ "00972527691234\n"
+ "972527691234\n"
+ "+972527691234\n";
final String subst = "0$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}