#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http[s]?:\/\/[^\/]*\.[a-z]+\/?$"
Local $sString = "https://www.feetrader.com/jobPostings" & @CRLF & _
"http://www.bienesonline.es/asociarse/" & @CRLF & _
"http://www.bienesonline.mx/asociarse/" & @CRLF & _
"http://www.bienesonline.cl/asociarse/" & @CRLF & _
"http://www.bienesonline.co/asociarse/" & @CRLF & _
"http://www.geralimoveis.com.br/produtos/" & @CRLF & _
"http://usa.bienesonline.com/asociarse/" & @CRLF & _
"http://www.informatik.uni-linz.ac.at/jobs/" & @CRLF & _
"http://informatik.jku.at/jobs/" & @CRLF & _
"https://2012.nosql-matters.org/bcn/" & @CRLF & _
"https://www.mapmeo.com/partner" & @CRLF & _
"http://www.revistapremier.com.br/contemporanea/" & @CRLF & _
"https://zippyapp.com/business" & @CRLF & _
"http://graph.storn.es/" & @CRLF & _
"http://www.volcanicinternet.com/portfolio/" & @CRLF & _
"http://imobsync.com.br/" & @CRLF & _
"http://trovit.com.isdownorblocked.com/" & @CRLF & _
"http://infoday.hoyu.edu.hk/test/" & @CRLF & _
"http://2016.desymfony.com/patrocinadores" & @CRLF & _
"https://osclass.com/en/" & @CRLF & _
"https://imobtic.com.br/" & @CRLF & _
"http://www.trovit.at-s.seohighscore.com/" & @CRLF & _
"https://dom.yuga.ru/sites/" & @CRLF & _
"https://www.kadaza.com/classifieds" & @CRLF & _
"http://www.oxleyrobert.com/" & @CRLF & _
"http://blog.trovit.de/" & @CRLF & _
"http://job.trovit.at/" & @CRLF & _
"https://www.sistemarsi.com/privacy" & @CRLF & _
"https://www.docjobs.at/" & @CRLF & _
"https://www.bienesonline.com.ar/asociarse/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")