package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http[s]?:\/\/[^\/]*\.[a-z]+\/?$`)
var str = `https://www.feetrader.com/jobPostings
http://www.bienesonline.es/asociarse/
http://www.bienesonline.mx/asociarse/
http://www.bienesonline.cl/asociarse/
http://www.bienesonline.co/asociarse/
http://www.geralimoveis.com.br/produtos/
http://usa.bienesonline.com/asociarse/
http://www.informatik.uni-linz.ac.at/jobs/
http://informatik.jku.at/jobs/
https://2012.nosql-matters.org/bcn/
https://www.mapmeo.com/partner
http://www.revistapremier.com.br/contemporanea/
https://zippyapp.com/business
http://graph.storn.es/
http://www.volcanicinternet.com/portfolio/
http://imobsync.com.br/
http://trovit.com.isdownorblocked.com/
http://infoday.hoyu.edu.hk/test/
http://2016.desymfony.com/patrocinadores
https://osclass.com/en/
https://imobtic.com.br/
http://www.trovit.at-s.seohighscore.com/
https://dom.yuga.ru/sites/
https://www.kadaza.com/classifieds
http://www.oxleyrobert.com/
http://blog.trovit.de/
http://job.trovit.at/
https://www.sistemarsi.com/privacy
https://www.docjobs.at/
https://www.bienesonline.com.ar/asociarse/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}