use strict;
my $str = 'https://www.feetrader.com/jobPostings
http://www.bienesonline.es/asociarse/
http://www.bienesonline.mx/asociarse/
http://www.bienesonline.cl/asociarse/
http://www.bienesonline.co/asociarse/
http://www.geralimoveis.com.br/produtos/
http://usa.bienesonline.com/asociarse/
http://www.informatik.uni-linz.ac.at/jobs/
http://informatik.jku.at/jobs/
https://2012.nosql-matters.org/bcn/
https://www.mapmeo.com/partner
http://www.revistapremier.com.br/contemporanea/
https://zippyapp.com/business
http://graph.storn.es/
http://www.volcanicinternet.com/portfolio/
http://imobsync.com.br/
http://trovit.com.isdownorblocked.com/
http://infoday.hoyu.edu.hk/test/
http://2016.desymfony.com/patrocinadores
https://osclass.com/en/
https://imobtic.com.br/
http://www.trovit.at-s.seohighscore.com/
https://dom.yuga.ru/sites/
https://www.kadaza.com/classifieds
http://www.oxleyrobert.com/
http://blog.trovit.de/
http://job.trovit.at/
https://www.sistemarsi.com/privacy
https://www.docjobs.at/
https://www.bienesonline.com.ar/asociarse/';
my $regex = qr/^http[s]?:\/\/[^\/]*\.[a-z]+\/?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}