# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^http[s]?:\/\/[^\/]*\.[a-z]+\/?$"
test_str = ("https://www.feetrader.com/jobPostings\n"
"http://www.bienesonline.es/asociarse/\n"
"http://www.bienesonline.mx/asociarse/\n"
"http://www.bienesonline.cl/asociarse/\n"
"http://www.bienesonline.co/asociarse/\n"
"http://www.geralimoveis.com.br/produtos/\n"
"http://usa.bienesonline.com/asociarse/\n"
"http://www.informatik.uni-linz.ac.at/jobs/\n"
"http://informatik.jku.at/jobs/\n"
"https://2012.nosql-matters.org/bcn/\n"
"https://www.mapmeo.com/partner\n"
"http://www.revistapremier.com.br/contemporanea/\n"
"https://zippyapp.com/business\n"
"http://graph.storn.es/\n"
"http://www.volcanicinternet.com/portfolio/\n"
"http://imobsync.com.br/\n"
"http://trovit.com.isdownorblocked.com/\n"
"http://infoday.hoyu.edu.hk/test/\n"
"http://2016.desymfony.com/patrocinadores\n"
"https://osclass.com/en/\n"
"https://imobtic.com.br/\n"
"http://www.trovit.at-s.seohighscore.com/\n"
"https://dom.yuga.ru/sites/\n"
"https://www.kadaza.com/classifieds\n"
"http://www.oxleyrobert.com/\n"
"http://blog.trovit.de/\n"
"http://job.trovit.at/\n"
"https://www.sistemarsi.com/privacy\n"
"https://www.docjobs.at/\n"
"https://www.bienesonline.com.ar/asociarse/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.