package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)hello=[a-z\s0-9]+&op=[a-z0-9]*`)
var str = `&hello=HI1&op=1h23&hello=&op=&hello=HI3&op=&hello=HI4&op=OP4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}