$re = '/hello=[a-z\s0-9]+&op=[a-z0-9]*/i';
$str = '&hello=HI1&op=1h23&hello=&op=&hello=HI3&op=&hello=HI4&op=OP4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);