const regex = /hello=[a-z\s0-9]+&op=[a-z0-9]*/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('hello=[a-z\\s0-9]+&op=[a-z0-9]*', 'gi')
const str = `&hello=HI1&op=1h23&hello=&op=&hello=HI3&op=&hello=HI4&op=OP4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}