use strict;
my $str = '
Now instead of numbers in the status column, there are words like *Assigned* and *Completed*. For an example that uses an image column to display an icon for process statuses, see the [Display Processes by Process Model with Status Icons](SAIL_Recipes.md#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe.
## <a id="Add_a_Predefined_Filter"></a> Add a Predefined Filter ##
(#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe.';
my $regex = qr/(SAIL_Recipes\.md)(\#)(.*?)(?=\))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}