re = /(SAIL_Recipes\.md)(\#)(.*?)(?=\))/mi
str = '
Now instead of numbers in the status column, there are words like *Assigned* and *Completed*. For an example that uses an image column to display an icon for process statuses, see the [Display Processes by Process Model with Status Icons](SAIL_Recipes.md#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe.
## <a id="Add_a_Predefined_Filter"></a> Add a Predefined Filter ##
(#Display_Processes_by_Process_Model_with_Status_Icons) SAIL recipe.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end