using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\s*[A-Z]+\]\ \{\""payload\""\:";
string input = @"[market-feed-render-4][user=xx.Xxxxx.Xxxx] [OUT] {""payload"":{""id"":""1562500842791.7273668"",""timestamp"":""2019-07-09T15:25:39.303Z"",""messages"":
[guiapi-msg-processors-4][user=XX.XXXX] [ IN] {""payload"":{""command"":{""requestContext"":""clob2"",""commandName"":""metrics"",""commandSubType"":""UIResourceUsage"",""commandParams"":{""metrics"":";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}