// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[\s*[A-Z]+\]\ \{\"payload\"\:"#).unwrap();
let string = "[market-feed-render-4][user=xx.Xxxxx.Xxxx] [OUT] {\"payload\":{\"id\":\"1562500842791.7273668\",\"timestamp\":\"2019-07-09T15:25:39.303Z\",\"messages\":
[guiapi-msg-processors-4][user=XX.XXXX] [ IN] {\"payload\":{\"command\":{\"requestContext\":\"clob2\",\"commandName\":\"metrics\",\"commandSubType\":\"UIResourceUsage\",\"commandParams\":{\"metrics\":";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}