import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\s*[A-Z]+\\]\\ \\{\\\"payload\\\"\\:";
final String string = "[market-feed-render-4][user=xx.Xxxxx.Xxxx] [OUT] {\"payload\":{\"id\":\"1562500842791.7273668\",\"timestamp\":\"2019-07-09T15:25:39.303Z\",\"messages\":\n"
+ "[guiapi-msg-processors-4][user=XX.XXXX] [ IN] {\"payload\":{\"command\":{\"requestContext\":\"clob2\",\"commandName\":\"metrics\",\"commandSubType\":\"UIResourceUsage\",\"commandParams\":{\"metrics\":";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}