re = /\[\s*[A-Z]+\]\ \{\"payload\"\:/m
str = '[market-feed-render-4][user=xx.Xxxxx.Xxxx] [OUT] {"payload":{"id":"1562500842791.7273668","timestamp":"2019-07-09T15:25:39.303Z","messages":
[guiapi-msg-processors-4][user=XX.XXXX] [ IN] {"payload":{"command":{"requestContext":"clob2","commandName":"metrics","commandSubType":"UIResourceUsage","commandParams":{"metrics":'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end