using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^:](\/\/.+)|(\/\*[\W\w\n\r]+?\*\/)";
string input = @"function DoStuff() {
/* This contains the value of foo.
Foo is used to display ""foo""
via http://stackoverflow.com
*/
this.foo = ""http://google.com"";
this.protocolAgnosticUrl = ""//cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/core.js"";
//Show a message about foo
alert(this.foo);
/// This is a triple-slash comment!
const globPatterns = [
'path/to/**/*.tests.js',
'!my-file.js',
""!**/folder/*"",
'another/path/**/*.tests.js'
];
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}