re = /[^:](\/\/.+)|(\/\*[\W\w\n\r]+?\*\/)/
str = 'function DoStuff() {
/* This contains the value of foo.
Foo is used to display "foo"
via http://stackoverflow.com
*/
this.foo = "http://google.com";
this.protocolAgnosticUrl = "//cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/core.js";
//Show a message about foo
alert(this.foo);
/// This is a triple-slash comment!
const globPatterns = [
\'path/to/**/*.tests.js\',
\'!my-file.js\',
"!**/folder/*",
\'another/path/**/*.tests.js\'
];
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end