import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^:](\\/\\/.+)|(\\/\\*[\\W\\w\\n\\r]+?\\*\\/)";
final String string = "function DoStuff() {\n"
+ " /* This contains the value of foo.\n"
+ " Foo is used to display \"foo\"\n"
+ " via http://stackoverflow.com\n"
+ " */\n"
+ " this.foo = \"http://google.com\";\n"
+ " this.protocolAgnosticUrl = \"//cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/core.js\";\n\n"
+ " //Show a message about foo\n"
+ " alert(this.foo);\n\n"
+ " /// This is a triple-slash comment!\n\n"
+ " const globPatterns = [\n"
+ " 'path/to/**/*.tests.js',\n"
+ " '!my-file.js',\n"
+ " \"!**/folder/*\",\n"
+ " 'another/path/**/*.tests.js'\n"
+ " ];\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}