// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^:](\/\/.+)|(\/\*[\W\w\n\r]+?\*\/)").unwrap();
let string = "function DoStuff() {
/* This contains the value of foo.
Foo is used to display \"foo\"
via http://stackoverflow.com
*/
this.foo = \"http://google.com\";
this.protocolAgnosticUrl = \"//cdnjs.cloudflare.com/ajax/libs/jquery/3.2.1/core.js\";
//Show a message about foo
alert(this.foo);
/// This is a triple-slash comment!
const globPatterns = [
'path/to/**/*.tests.js',
'!my-file.js',
\"!**/folder/*\",
'another/path/**/*.tests.js'
];
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}