package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *(?:--)([\w-]+)(?:=((?:[\w-]| \w)+))?|(.*)`)
var str = `--match1=match2
--match1=match2 match2
--match1=match2 match2-match2
--mat-ch1=match2 match2
--match1=match2-match2 match2
--match1=match2 -lastmatch
--match1=match2 --lastmatch
--match1 -lastmatch
--match1 --lastmatch
lastormatch`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}