re = /^ *(?:--)([\w-]+)(?:=((?:[\w-]| \w)+))?|(.*)/m
str = '--match1=match2
--match1=match2 match2
--match1=match2 match2-match2
--mat-ch1=match2 match2
--match1=match2-match2 match2
--match1=match2 -lastmatch
--match1=match2 --lastmatch
--match1 -lastmatch
--match1 --lastmatch
lastormatch'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end