package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+([^\d]{0,2}\d){11}$`)
var str = `+7 (961) 772-86-22
+7 (961)772-86-22
+7 (961)772-8622
+3 (123) 123-12-32
+7 (961)7728622
+7961772-86-22
+7 (9 6 1) 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2 3 4
+7 9 6 1 7 7 2 8 6 2
+7 961 77 286 22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}