// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+([^\d]{0,2}\d){11}$").unwrap();
let string = "+7 (961) 772-86-22
+7 (961)772-86-22
+7 (961)772-8622
+3 (123) 123-12-32
+7 (961)7728622
+7961772-86-22
+7 (9 6 1) 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2 3 4
+7 9 6 1 7 7 2 8 6 2
+7 961 77 286 22";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}