import Foundation
let pattern = #"^\+([^\d]{0,2}\d){11}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+7 (961) 772-86-22
+7 (961)772-86-22
+7 (961)772-8622
+3 (123) 123-12-32
+7 (961)7728622
+7961772-86-22
+7 (9 6 1) 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2
+7 9 6 1 7 7 2 8 6 2 2 3 4
+7 9 6 1 7 7 2 8 6 2
+7 961 77 286 22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)