# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\+([^\d]{0,2}\d){11}$"
test_str = ("+7 (961) 772-86-22\n"
"+7 (961)772-86-22\n"
"+7 (961)772-8622\n"
"+3 (123) 123-12-32\n"
"+7 (961)7728622\n"
"+7961772-86-22\n"
"+7 (9 6 1) 7 7 2 8 6 2 2\n"
"+7 9 6 1 7 7 2 8 6 2 2\n"
"+7 9 6 1 7 7 2 8 6 2 2 3 4\n"
"+7 9 6 1 7 7 2 8 6 2\n"
"+7 961 77 286 22")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.