re = /OTP(\s+):(\s+)(\d+)/m
str = ' {"status":"Success","data":{"PhoneNumber":"768909764","Body":"Please use OTP : 563991 to complete the process"},"error":null,"pagination":null,"condition":null}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end