// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)OTP(\s+):(\s+)(\d+)").unwrap();
let string = " {\"status\":\"Success\",\"data\":{\"PhoneNumber\":\"768909764\",\"Body\":\"Please use OTP : 563991 to complete the process\"},\"error\":null,\"pagination\":null,\"condition\":null}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}