using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([:|.|?|!|,][^\s])|([ж|ш]ы)|(координально|сдесь|зделал|зделаю|зделан)|([^,][\s](но|а)[\s])";
string input = @"Как у вас но здесь оно самое, неплохо? ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}