const regex = /([:|.|?|!|,][^\s])|([ж|ш]ы)|(координально|сдесь|зделал|зделаю|зделан)|([^,][\s](но|а)[\s])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([:|.|?|!|,][^\\s])|([ж|ш]ы)|(координально|сдесь|зделал|зделаю|зделан)|([^,][\\s](но|а)[\\s])', 'g')
const str = `Как у вас но здесь оно самое, неплохо? `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}