package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([:|.|?|!|,][^\s])|([ж|ш]ы)|(координально|сдесь|зделал|зделаю|зделан)|([^,][\s](но|а)[\s])`)
var str = `Как у вас но здесь оно самое, неплохо? `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}