re = /([:|.|?|!|,][^\s])|([ж|ш]ы)|(координально|сдесь|зделал|зделаю|зделан)|([^,][\s](но|а)[\s])/
str = 'Как у вас но здесь оно самое, неплохо? '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end