#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^\/var\/)log"
Local $sString = "/var/log/foo/var/bar" & @CRLF & _
"/var/log/foo/avarb/bar" & @CRLF & _
"/var/log/var/log" & @CRLF & _
"/var/log" & @CRLF & _
"/var/log/foo/bar" & @CRLF & _
"/var/test/var" & @CRLF & _
"/var/test/west" & @CRLF & _
"/var/test/west/log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")