using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^\/var\/)log";
string input = @"/var/log/foo/var/bar
/var/log/foo/avarb/bar
/var/log/var/log
/var/log
/var/log/foo/bar
/var/test/var
/var/test/west
/var/test/west/log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}