import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^\\/var\\/)log";
final String string = "/var/log/foo/var/bar\n"
+ "/var/log/foo/avarb/bar\n"
+ "/var/log/var/log\n"
+ "/var/log\n"
+ "/var/log/foo/bar\n"
+ "/var/test/var\n"
+ "/var/test/west\n"
+ "/var/test/west/log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}