$re = '/(?<!^\/var\/)log/m';
$str = '/var/log/foo/var/bar
/var/log/foo/avarb/bar
/var/log/var/log
/var/log
/var/log/foo/bar
/var/test/var
/var/test/west
/var/test/west/log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);