package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+ (\d+ -[^\-]+)( -.*)?$`)
var str = `Opcao 01 - Frase aleatória - Menu Superior
Opcao 02 - Outra Frase aleatória - Menu Su
Opcao 03 - Mais 01 Frase - Menu
Opcao 04 - Mais Frase -
Opcao 05 - Frase Simples`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}