$re = '/^\w+ (\d+ -[^\-]+)( -.*)?$/m';
$str = 'Opcao 01 - Frase aleatória - Menu Superior
Opcao 02 - Outra Frase aleatória - Menu Su
Opcao 03 - Mais 01 Frase - Menu
Opcao 04 - Mais Frase -
Opcao 05 - Frase Simples';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);