const regex = /^\w+ (\d+ -[^\-]+)( -.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+ (\\d+ -[^\\-]+)( -.*)?$', 'gm')
const str = `Opcao 01 - Frase aleatória - Menu Superior
Opcao 02 - Outra Frase aleatória - Menu Su
Opcao 03 - Mais 01 Frase - Menu
Opcao 04 - Mais Frase -
Opcao 05 - Frase Simples`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}