#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http[s]?|udp|rtp)\:\/\/+([a-z0-9._-]+(\:[0-9]+)?)(\/([a-zA-Z0-9_-]+|udp)\/(([a-zA-Z0-9_-]+)(.m3u8)|(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\:(\d{1,5}))?))?"
Local $sString = "http://tv.tvip-media.net/perviykanal/video.m3u8" & @CRLF & _
"http://tv.tvip-media.net:80/perviykanal/video.m3u8" & @CRLF & _
"udp://229.1.1.1:1234" & @CRLF & _
"http://udpxy.netsol.su:4022/udp/225.100.123.26:1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")