re = /^(http[s]?|udp|rtp)\:\/\/+([a-z0-9._-]+(\:[0-9]+)?)(\/([a-zA-Z0-9_-]+|udp)\/(([a-zA-Z0-9_-]+)(.m3u8)|(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\:(\d{1,5}))?))?/m
str = 'http://tv.tvip-media.net/perviykanal/video.m3u8
http://tv.tvip-media.net:80/perviykanal/video.m3u8
udp://229.1.1.1:1234
http://udpxy.netsol.su:4022/udp/225.100.123.26:1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end