import re
regex = re.compile(r"^(http[s]?|udp|rtp)\:\/\/+([a-z0-9._-]+(\:[0-9]+)?)(\/([a-zA-Z0-9_-]+|udp)\/(([a-zA-Z0-9_-]+)(.m3u8)|(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\:(\d{1,5}))?))?", flags=re.MULTILINE)
test_str = ("http://tv.tvip-media.net/perviykanal/video.m3u8\n"
"http://tv.tvip-media.net:80/perviykanal/video.m3u8\n"
"udp://229.1.1.1:1234\n"
"http://udpxy.netsol.su:4022/udp/225.100.123.26:1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")