#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\d\/\.\-\+]+(?:\s?;?(\s+)?((?:boundary|charset)\s?=\s?['\"\w\d\.\-]+)?;?(\s+)?)?(?:\s?(?:gzip|deflate|br|,)+\s?;?(\s+)?)?$"
Local $sString = "application/x-www-form-urlencoded" & @CRLF & _
"application/x-www-form-urlencoded;" & @CRLF & _
"application/x-www-form-urlencoded; charset=utf-8;" & @CRLF & _
"application/x-www-form-urlencoded; charset=utf-8;gzip,deflate; " & @CRLF & _
"application/x-www-form-urlencoded; charset=utf-8;gzip,deflate,br; "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")