package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\d\/\.\-\+]+(?:\s?;?(\s+)?((?:boundary|charset)\s?=\s?['\"\w\d\.\-]+)?;?(\s+)?)?(?:\s?(?:gzip|deflate|br|,)+\s?;?(\s+)?)?$`)
var str = `application/x-www-form-urlencoded
application/x-www-form-urlencoded;
application/x-www-form-urlencoded; charset=utf-8;
application/x-www-form-urlencoded; charset=utf-8;gzip,deflate;
application/x-www-form-urlencoded; charset=utf-8;gzip,deflate,br; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}