import Foundation
let pattern = #"^[\w\d\/\.\-\+]+(?:\s?;?(\s+)?((?:boundary|charset)\s?=\s?['\"\w\d\.\-]+)?;?(\s+)?)?(?:\s?(?:gzip|deflate|br|,)+\s?;?(\s+)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
application/x-www-form-urlencoded
application/x-www-form-urlencoded;
application/x-www-form-urlencoded; charset=utf-8;
application/x-www-form-urlencoded; charset=utf-8;gzip,deflate;
application/x-www-form-urlencoded; charset=utf-8;gzip,deflate,br;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)