// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^[\w\d\/\.\-\+]+(?:\s?;?(\s+)?((?:boundary|charset)\s?=\s?['\"\w\d\.\-]+)?;?(\s+)?)?(?:\s?(?:gzip|deflate|br|,)+\s?;?(\s+)?)?$"#).unwrap();
let string = "application/x-www-form-urlencoded
application/x-www-form-urlencoded;
application/x-www-form-urlencoded; charset=utf-8;
application/x-www-form-urlencoded; charset=utf-8;gzip,deflate;
application/x-www-form-urlencoded; charset=utf-8;gzip,deflate,br; ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}