use strict;
my $str = 'Av. Moinho Fabrini, 600 - Independencia, Sao Bernardo do Campo - SP, 09862-160
SAO BERNARDO DO CAMPO STATE OF SAO PAULO BRAZIL RUA VICENTE DE CARVALHO 197 09726 600
RUA JOAO PESSOA, 420, CENTRO, SAO BERNARDO DO CAMPO - SAO PAULO, 09715-000, BRASIL
AV. ROBERT KENNEDY. 3095 - ASSUNCAO SAO BERNARDO DO CAMPO - SP. 09860-215';
my $regex = qr/((?:|\s)\w+(?:\.|))(?:|,|\.)\s(\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}